Sesame Provider tests failing

Matters relating to SQL, RDF, XML, and Free Text data management

Sesame Provider tests failing

Postby Shepard on Fri Feb 13, 2009 7:42 am

Hi,

I downloaded and installed Virtuoso Open-Source Edition v5.0.9 on Ubuntu yesterday and started the server like described on http://virtuoso.openlinksw.com/dataspace/dav/wiki/Main/VOSMake#Getting%20Started. I also downloaded the JAR files for the Sesame Provider.
When trying to incorporate the VirtuosoRepository from the provider into my application I noticed that files I added to the store didn't appear in it, i.e. querying it afterwards returned no results. So I tried the VirtuosoTest class from the sample programs download and indeed that class failed two tests:

Code: Select all
== TEST 3:  : Start
   Loading data from file: virtuoso_driver/data.nt
== TEST 3:  : End
***FAILED: TEST 3


and

Code: Select all
== TEST 8:  : Start
   Statement does not exists
== TEST 8:  : End
***FAILED: TEST 8


No exceptions, nothing. I also double-checked that it can actually find the data.nt file and it can find it fine. Weird enough the test which adds data from a URI (Kingsley's FOAF) worked - but in my application when I tried to load the file through a file: URI instead of using a File object it didn't work either.

So, did I miss a step somewhere, do I have to activate anything on the server? Or can you confirm that there's a bug in the current version?

Thanks,
Simon
Shepard
 
Posts: 5
Joined: Fri Feb 13, 2009 7:20 am

Re: Sesame Provider tests failing

Postby hwilliams on Fri Feb 13, 2009 10:53 am

Hi Simon,

Can you please provide the following:

1. The version of Sesame being used
2. Turn on tracing in virtuoso Which enables detailed and controlled logging of Virtuoso server
activity to be added to the virtuoso log file including queries being
executedas detailed at:

http://docs.openlinksw.com/virtuoso/fn_ ... html#(NULL)

3. The contents of the virtuoso.log file after executing the VirtuosoTest class
4. The compete output of running the VirtuosoTest class

Best Regards
Hugh Williams
Professional Services
OpenLink Software
Web: http://www.openlinksw.com
Support: http://support.openlinksw.com
Forums: http://boards.openlinksw.com/support
hwilliams
 
Posts: 1042
Joined: Thu Mar 06, 2008 4:30 am

Re: Sesame Provider tests failing

Postby Shepard on Fri Feb 13, 2009 11:30 am

Sesame version is the latest, 2.2.4.
The log and the output of the test class are attached.
Attachments
VirtuosoTest_output.log
(2.57 KiB) Downloaded 233 times
virtuoso.log
(30.42 KiB) Downloaded 239 times
Shepard
 
Posts: 5
Joined: Fri Feb 13, 2009 7:20 am

Re: Sesame Provider tests failing

Postby hwilliams on Mon Feb 16, 2009 8:40 am

Hi Simon,

We are seeing these two test failures with the VOS 5.0.9 and new 5.0.10 release that went out on Friday and are currently looking into the cause of these failures. I shall report back to you once they are resolved.

Best Regards
Hugh Williams
Professional Services
OpenLink Software
Web: http://www.openlinksw.com
Support: http://support.openlinksw.com
Forums: http://boards.openlinksw.com/support
hwilliams
 
Posts: 1042
Joined: Thu Mar 06, 2008 4:30 am

Re: Sesame Provider tests failing

Postby Shepard on Tue Feb 17, 2009 10:20 am

Ok, thanks!
Shepard
 
Posts: 5
Joined: Fri Feb 13, 2009 7:20 am

Re: Sesame Provider tests failing

Postby Shepard on Tue Feb 17, 2009 5:30 pm

Btw, I also noted that VirtuosoRepositoryConnection.getValueFactory() throws an AbstractMethodError. So I have to work around that at the moment by calling connection.getRepository().getValueFactory();
Shepard
 
Posts: 5
Joined: Fri Feb 13, 2009 7:20 am

Re: Sesame Provider tests failing

Postby hwilliams on Fri Feb 20, 2009 9:57 pm

Hi Simon,

We are not able to replicate the problem you report with the VirtuosoRepositoryConnection.getValueFactory() method, thus can you provide some sample/pseudo code to enable us to attempt a recreation in-house ?

Best Regards
Hugh Williams
OpenLink Software
hwilliams
 
Posts: 1042
Joined: Thu Mar 06, 2008 4:30 am

Re: Sesame Provider tests failing

Postby Shepard on Mon Mar 02, 2009 6:13 pm

Hi Hugh,

Sorry for the late reply.
I attached some Java code (username and password removed, have to be filled in again) which simply gets a repository and a connection from it and tries to access the value factory. It fails with the following exception:

Exception in thread "main" java.lang.AbstractMethodError: virtuoso.sesame2.driver.VirtuosoRepositoryConnection.getValueFactory()Lorg/openrdf/model/ValueFactory;
at org.parroters.test.VirtuosoValueFactoryTest.main(VirtuosoValueFactoryTest.java:20)

Now normally with such errors I'd think I'm missing some classes but I can't see how. And I have virt_sesame2.jar and virtjdbc3.jar in my classpath.

Thanks,
Simon
Attachments
VirtuosoValueFactoryTest.txt
(635 Bytes) Downloaded 220 times
Shepard
 
Posts: 5
Joined: Fri Feb 13, 2009 7:20 am


Return to Virtuoso - Native Data Management

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests