...failed to start because jvm.dll was not found

ODBC Drivers related matters.

...failed to start because jvm.dll was not found

Postby drbobjr on Wed Jun 02, 2010 11:53 am

Can't set up a ODBC data source with the OpenLink ODBC-JDBC bridge. The OpenLink driver installed fine on both XP (32) and Windows 7 (64). But, when trying to actually create a data source and selecting the "OpenLink Lite for JDK 1.5" driver, I get the error "This application has failed to start because jvm.dll was not found. Re-installing the application may fix this problem." Closing that error box, I get another "Can't load driver" box that lists "C:\Program Files\OpenLink Software\UDA\bin\ntl5j15z.dll"

I've loaded the JRE and the JDK several times. In fact, there are 10 instances of jvm.dll on my machine. I've re-installed OpenLink several times with re-boots between each.

I'm out of ideas. Any help would be most appreciated.

Thanks,

- Bob
drbobjr
 
Posts: 3
Joined: Wed Jun 02, 2010 11:35 am

Re: ...failed to start because jvm.dll was not found

Postby gazbiggs on Fri Jun 04, 2010 10:28 am

Hi Bob,

It seems there is a small section missing from our documentation....

Basically, you will need to set your %Path% environment variable to point to the directory containing jvm.dll on your machine.

Typically, this is something like --

C:\Program Files\Java\jre6\bin\client

Please note:

1) This is the *directory* containing jvm.dll and does not include the filename (jvm.dll)

2) On Windows 64bit operating systems - there may be both 32bit and 64bit dll's. Make sure you include the correct directory in %Path%.

That is, if you have a 32bit ODBC application then you will need a 32bit Brige and corresponding 32bit jvm.dll.

Ditto for 64bit.

I hope this makes sense?

Regards,

Garry M. Biggs
Technical Support
OpenLink Software
http://www.openlinksw.com
Product Weblogs:
Virtuoso: http://www.openlinksw.com/weblogs/virtuoso
UDA: http://www.openlinksw.com/weblogs/uda
Universal Data Access & Virtual Database Technology
Twitter: http://twitter.com/openlink
Regards,

Garry M. Biggs
Technical Support
OpenLink Software, Inc. // http://www.openlinksw.com/
10 Burlington Mall Road, Suite 265, Burlington MA 01803
Weblog -- http://www.openlinksw.com/blogs/
LinkedIn -- http://www.linkedin.com/company/openlink-software/
Twitter -- http://twitter.com/OpenLink
Google+ -- http://plus.google.com/100570109519069333827/
Facebook -- http://www.facebook.com/OpenLinkSoftware
Universal Data Access, Integration, and Management Technology Providers
gazbiggs
 
Posts: 244
Joined: Tue Feb 26, 2008 10:38 am

Re: ...failed to start because jvm.dll was not found

Postby drbobjr on Sun Jun 06, 2010 2:26 pm

Gary,

That was it. Thanks!!!!!

- Bob
drbobjr
 
Posts: 3
Joined: Wed Jun 02, 2010 11:35 am

Re: ...failed to start because jvm.dll was not found

Postby Gendoo on Tue Oct 25, 2011 1:59 am

Thnx for the help, Gary, I got an error message saying that the application has failed to start because jvm.dll was not found, reinstalling of the JDK didn't make any difference.
Last edited by Gendoo on Mon Jun 18, 2012 6:14 am, edited 2 times in total.
Gendoo
 
Posts: 1
Joined: Tue Oct 25, 2011 1:54 am

Re: ...failed to start because jvm.dll was not found

Postby wdance on Tue Oct 25, 2011 5:15 am

Hello,

If you are sure that you have run the installation successfully. (This can be proved by opening up a command prompt and typing 'java -version')

If you get a version returned then this shows its installed. Once this is proved you must also make sure that the FULL path to the jvm.dll is added to your System Environment Variables, a quick test is if you run the 'set' command from the same command prompt this will display all the currently set environment variables.

Kind regards,

Wez Dance
Professional Services
OpenLink Software
http://www.openlinksw.com
Product Weblogs:
Virtuoso: http://www.openlinksw.com/weblogs/virtuoso
UDA: http://www.openlinksw.com/weblogs/uda
Universal Data Access & Virtual Database Technology
Twitter: http://twitter.com/openlink
wdance
 
Posts: 171
Joined: Mon Oct 19, 2009 6:30 am

Re: ...failed to start because jvm.dll was not found

Postby carolyn56 on Fri Nov 04, 2011 1:27 am

Thank you very much, your solution and advice worked and helped me!!!
carolyn56
 
Posts: 1
Joined: Fri Nov 04, 2011 1:25 am


Return to Open Database Connectivity (ODBC)

Who is online

Users browsing this forum: No registered users and 1 guest

cron